Vyattaに初期設定を行ってみた
Pocket

先日Proxmox VE 3.1にインストールしたVyattaに対し、ルータとしての初期設定を行ってみた。
今回行う初期設定は以下。

  • host名の設定
  • 固定IPアドレスの設定
  • sshサービスの起動
  • DHCPサーバ起動
  • DNSサーバ設定
  • NTPサーバ設定
  • NAT設定

NATやFirewallの設定についてはまた後日行うことにした。

host名の設定

まずはVyattaのhost名を設定する。「configure」コマンドでconfigモード(設定モード)に以降し、以下のコマンドを実行する。

set system host-name <ホスト名>

なお、設定後に以下のコマンドで決定、再起動後にも設定を保持させるようにする。
これは以降の設定でも同じ。

commit
save

Sponsored Links

固定IPアドレスの設定

初期設定としては必ず行われるであろう設定。
ここでは、アドレスを「192.168.0.191/24」「192.168.11.191/24」として設定する。

 set interfaces ethernet eth0 address 192.168.0.191/24
 set interfaces ethernet eth1 address 192.168.11.191/24

また、以下のコマンドを実行して既存のルータへデフォルトゲートウェイを設定する。

 set system gateway-address <既存ルータのIP>

sshサービスの起動

Vyattaを使用する上で、いちいちProxmoxのコンソールから操作するのは不便でしょうがない。
そこで、sshを有効化して操作の利便性を向上させる。

なお、2行目のコマンドでsshを利用できる接続先IPアドレスを「192.168.0.191」に制限している。

 set service ssh
 set service ssh listen-address 192.168.0.191

以降はsshで接続する。

DHCPサーバ起動

ルーターといえばDHCP。ということで、DHCPサーバとしても稼働させるようにした。

 set service dhcp-server shared-network-name ETH0 subnet 192.168.0.0/24 start 192.168.0.200 stop 192.168.0.250
 set service dhcp-server shared-network-name ETH0 subnet 192.168.0.0/24 default-router 192.168.0.191
 set service dhcp-server shared-network-name ETH0 subnet 192.168.0.0/24 dns-server DNSサーバ

DNSサーバ設定

Vyattaの参照するDNSサーバの設定。残念ながらDNSサーバとしての機能は標準機能としては提供されていないので、ここでは記述しない。(一応、apt-getでBINDをインストールすれば追加可能の様子。)

 set system name-server 8.8.8.8

NTPサーバ設定

VyattaでのNTPサーバ参照設定。
(なおVyatta上ではntpdが稼働してるので、おそらくNTPサーバとしても使用できる?)

 set system ntp server NTPサーバ
 set system time-zone Asia/Tokyo

NTPの設定ができているかを確認。
Operationモード(一般モード)で以下のコマンドを実行。

 show ntp

NAT設定

家庭にすでにあるルータとの連携でスタティックルートを設定する場合、Vyattaだけではなくそちらのルータにも設定が必要になってしまうので、仮でNATを設定する。
以下の設定で、eth1に接続されている機器からはインターネットやeth0側の機器が見えるが、外からeth1の機器は見れないような状態にする。

NATそのものについては、こちらを見るとわかりやすい。

 set nat source rule 1 source address 192.168.11.0/24
 set nat source rule 1 outbound-interface eth0
 set nat source rule 1 translation address masquerade

とりあえず以上。Vyattaの設定についてはいろんな方がしているので、参考になるサイトを羅列してみる。

自宅ルータをVyattaにして快適になった

http://blog.kenjiskywalker.org/blog/2013/09/10/vyatta-ubuntu/

ソフトウェアルーター Vyatta 6.3 の接続設定

https://faq.interlink.or.jp/faq2/View/wcDisplayContent.aspx?id=1189

自宅ルータをVyattaに移行しました

http://d.hatena.ne.jp/mikeda/20120331/1333172105

自宅ルーターをvyattaに。 VC6.5R1 編

http://d.hatena.ne.jp/byoRF/20121217/1356002194

Pocket

Written by blacknon

インフラ系のSE。一時期はプログラマ。 仮想化とオープンソースに興味あり。一日中寝てたい今日このごろ。 スペインとかで働きたいなぁ…(シエスタがあるので)

Leave a Comment

メールアドレスが公開されることはありません。