CentOS 7でrsyslog 8.xをインストールする

CentOS 7では、バンドルされているrsyslogのバージョンは7系になっている。
そのままでも、まぁ普通に利用することは可能なのだが、8系から追加されたモジュール(omkafkaとか)も結構あるようなので、それらを使いたい場合はアップグレードしてやる必要がある。

CentOS 7でrsyslog 8.x系に乗り換えるには、オフィシャルで用意されているリポジトリを入れてやると楽だろう。

wget http://rpms.adiscon.com/v8-stable/rsyslog.repo -O /etc/yum.repos.d/rsyslog.repo
yum install rsyslog* --skip-broken
Sponsored Links

[root@BS-PUB-CENT7-02 ~]# yum install rsyslog* --skip-broken
読み込んだプラグイン:fastestmirror, rhnplugin
rsyslog_v8                                                              | 2.5 kB  00:00:00
rsyslog_v8/7/x86_64/primary_db                                          | 214 kB  00:00:00
Loading mirror speeds from cached hostfile
* base: ftp.riken.jp
* epel: mirror.ehost.vn
* extras: ftp.riken.jp
* remi-safe: mirror.smartmedia.net.id
* updates: ftp.riken.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ rsyslog.x86_64 0:7.4.7-12.el7 を 更新
---> パッケージ rsyslog.x86_64 0:8.24.0-2.el7 を アップデート
--> 依存性の処理をしています: libgt のパッケージ: rsyslog-8.24.0-2.el7.x86_64
--> 依存性の処理をしています: libgthttp.so.0()(64bit) のパッケージ: rsyslog-8.24.0-2.el7.x86_64
--> 依存性の処理をしています: libgtbase.so.0()(64bit) のパッケージ: rsyslog-8.24.0-2.el7.x86_64
--> 依存性の処理をしています: libfastjson.so.4()(64bit) のパッケージ: rsyslog-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-crypto.x86_64 0:7.4.7-16.el7 を インストール
--> 依存性の処理をしています: rsyslog = 7.4.7-16.el7 のパッケージ: rsyslog-crypto-7.4.7-16.el7.x86_64
---> パッケージ rsyslog-debuginfo.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-doc.x86_64 0:7.4.7-16.el7 を インストール
---> パッケージ rsyslog-elasticsearch.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-gnutls.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-gssapi.x86_64 0:7.4.7-16.el7 を インストール
--> 依存性の処理をしています: rsyslog = 7.4.7-16.el7 のパッケージ: rsyslog-gssapi-7.4.7-16.el7.x86_64
---> パッケージ rsyslog-kafka.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: librdkafka.so.1()(64bit) のパッケージ: rsyslog-kafka-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-ksi.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: libksi1 >= 3.4.0.0 のパッケージ: rsyslog-ksi-8.24.0-2.el7.x86_64
--> 依存性の処理をしています: libksi.so.1()(64bit) のパッケージ: rsyslog-ksi-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-libdbi.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: libdbi.so.0()(64bit) のパッケージ: rsyslog-libdbi-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-mmanon.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmaudit.x86_64 0:7.4.7-16.el7 を インストール
--> 依存性の処理をしています: rsyslog = 7.4.7-16.el7 のパッケージ: rsyslog-mmaudit-7.4.7-16.el7.x86_64
---> パッケージ rsyslog-mmfields.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmjsonparse.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmnormalize.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: liblognorm.so.5()(64bit) のパッケージ: rsyslog-mmnormalize-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-mmrm1stspace.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmsnmptrapd.x86_64 0:7.4.7-16.el7 を インストール
--> 依存性の処理をしています: rsyslog = 7.4.7-16.el7 のパッケージ: rsyslog-mmsnmptrapd-7.4.7-16.el7.x86_64
---> パッケージ rsyslog-mmutf8fix.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mongodb.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: libmongo-client.so.0(LMC_0.1.6)(64bit) のパッケージ: rsyslog-mongodb-8.24.0-2.el7.x86_64
--> 依存性の処理をしています: libmongo-client.so.0(LMC_0.1.1)(64bit) のパッケージ: rsyslog-mongodb-8.24.0-2.el7.x86_64
--> 依存性の処理をしています: libmongo-client.so.0(LMC_0.1.0)(64bit) のパッケージ: rsyslog-mongodb-8.24.0-2.el7.x86_64
--> 依存性の処理をしています: libmongo-client.so.0()(64bit) のパッケージ: rsyslog-mongodb-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-mysql.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-ommail.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-pgsql.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: libpq.so.5()(64bit) のパッケージ: rsyslog-pgsql-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-pmaixforwardedfrom.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-pmciscoios.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-relp.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: librelp >= 1.2.10 のパッケージ: rsyslog-relp-8.24.0-2.el7.x86_64
--> 依存性の処理をしています: librelp.so.0()(64bit) のパッケージ: rsyslog-relp-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-rsgtutil.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-snmp.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: libnetsnmp.so.31()(64bit) のパッケージ: rsyslog-snmp-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-udpspoof.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性の処理をしています: libnet.so.1()(64bit) のパッケージ: rsyslog-udpspoof-8.24.0-2.el7.x86_64
---> パッケージ rsyslog-utils.x86_64 0:8.14.0-5.el7 を インストール
--> 依存性の処理をしています: rsyslog = 8.14.0-5.el7 のパッケージ: rsyslog-utils-8.14.0-5.el7.x86_64
--> 依存性の処理をしています: libksi.so.0()(64bit) のパッケージ: rsyslog-utils-8.14.0-5.el7.x86_64
パッケージ libksi は libksi1 によって不要になりました。しかし、不要のパッケージは要求を提供していません。
--> トランザクションの確認を実行しています。
---> パッケージ libdbi.x86_64 0:0.8.4-6.el7 を インストール
---> パッケージ libfastjson4.x86_64 0:0.99.4-1.el7 を インストール
---> パッケージ libgt.x86_64 0:0.3.11-1.el7 を インストール
---> パッケージ libksi1.x86_64 0:3.4.0.7-1.el7 を インストール
---> パッケージ liblognorm5.x86_64 0:2.0.2-1.el7 を インストール
---> パッケージ libmongo-client.x86_64 0:0.1.8-1.el7 を インストール
---> パッケージ libnet.x86_64 0:1.1.6-7.el7 を インストール
---> パッケージ librdkafka.x86_64 0:0.9.3-1.el7.remi を インストール
---> パッケージ librelp.x86_64 0:1.2.12-1.el7 を インストール
---> パッケージ net-snmp-libs.x86_64 1:5.7.2-24.el7_2.1 を インストール
---> パッケージ postgresql-libs.x86_64 0:9.2.18-1.el7 を インストール
---> パッケージ rsyslog-crypto.x86_64 0:7.4.7-16.el7 を インストール
--> 依存性の処理をしています: rsyslog = 7.4.7-16.el7 のパッケージ: rsyslog-crypto-7.4.7-16.el7.x86_64
---> パッケージ rsyslog-gssapi.x86_64 0:7.4.7-16.el7 を インストール
--> 依存性の処理をしています: rsyslog = 7.4.7-16.el7 のパッケージ: rsyslog-gssapi-7.4.7-16.el7.x86_64
---> パッケージ rsyslog-mmaudit.x86_64 0:7.4.7-16.el7 を インストール
--> 依存性の処理をしています: rsyslog = 7.4.7-16.el7 のパッケージ: rsyslog-mmaudit-7.4.7-16.el7.x86_64
---> パッケージ rsyslog-mmsnmptrapd.x86_64 0:7.4.7-16.el7 を インストール
--> 依存性の処理をしています: rsyslog = 7.4.7-16.el7 のパッケージ: rsyslog-mmsnmptrapd-7.4.7-16.el7.x86_64
---> パッケージ rsyslog-utils.x86_64 0:8.14.0-5.el7 を インストール
--> 依存性の処理をしています: rsyslog = 8.14.0-5.el7 のパッケージ: rsyslog-utils-8.14.0-5.el7.x86_64
--> 依存性の処理をしています: libksi.so.0()(64bit) のパッケージ: rsyslog-utils-8.14.0-5.el7.x86_64
パッケージ libksi は libksi1 によって不要になりました。しかし、不要のパッケージは要求を提供していません。
base/7/x86_64/filelists_db                                              | 6.6 MB  00:00:00
rsyslog_v8/7/x86_64/filelists_db                                        | 197 kB  00:00:00
--> トランザクションの確認を実行しています。
---> パッケージ rsyslog-crypto.x86_64 0:7.4.7-16.el7 を インストール
---> パッケージ rsyslog-gssapi.x86_64 0:7.4.7-16.el7 を インストール
---> パッケージ rsyslog-mmaudit.x86_64 0:7.4.7-16.el7 を インストール
---> パッケージ rsyslog-mmsnmptrapd.x86_64 0:7.4.7-16.el7 を インストール
---> パッケージ rsyslog-utils.x86_64 0:8.14.0-5.el7 を インストール
--> トランザクションの確認を実行しています。
---> パッケージ libdbi.x86_64 0:0.8.4-6.el7 を インストール
---> パッケージ libfastjson4.x86_64 0:0.99.4-1.el7 を インストール
---> パッケージ libgt.x86_64 0:0.3.11-1.el7 を インストール
---> パッケージ libksi1.x86_64 0:3.4.0.7-1.el7 を インストール
---> パッケージ liblognorm5.x86_64 0:2.0.2-1.el7 を インストール
---> パッケージ libmongo-client.x86_64 0:0.1.8-1.el7 を インストール
---> パッケージ libnet.x86_64 0:1.1.6-7.el7 を インストール
---> パッケージ librdkafka.x86_64 0:0.9.3-1.el7.remi を インストール
---> パッケージ librelp.x86_64 0:1.2.12-1.el7 を インストール
---> パッケージ net-snmp-libs.x86_64 1:5.7.2-24.el7_2.1 を インストール
---> パッケージ postgresql-libs.x86_64 0:9.2.18-1.el7 を インストール
---> パッケージ rsyslog.x86_64 0:7.4.7-12.el7 を 更新
---> パッケージ rsyslog.x86_64 0:8.24.0-2.el7 を アップデート
---> パッケージ rsyslog-debuginfo.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-doc.x86_64 0:7.4.7-16.el7 を インストール
---> パッケージ rsyslog-elasticsearch.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-gnutls.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-kafka.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-ksi.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-libdbi.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmanon.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmfields.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmjsonparse.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmnormalize.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmrm1stspace.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mmutf8fix.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mongodb.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-mysql.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-ommail.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-pgsql.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-pmaixforwardedfrom.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-pmciscoios.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-relp.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-rsgtutil.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-snmp.x86_64 0:8.24.0-2.el7 を インストール
---> パッケージ rsyslog-udpspoof.x86_64 0:8.24.0-2.el7 を インストール
--> 依存性解決を終了しました。
パッケージは依存関係に問題があるため、飛ばします:
rsyslog-crypto-7.4.7-16.el7.x86_64 (base から)
rsyslog-gssapi-7.4.7-16.el7.x86_64 (base から)
rsyslog-mmaudit-7.4.7-16.el7.x86_64 (base から)
rsyslog-mmsnmptrapd-7.4.7-16.el7.x86_64 (base から)
rsyslog-utils-8.14.0-5.el7.x86_64 (rsyslog_v8 から)
依存性を解決しました
===============================================================================================
Package                          アーキテクチャー
バージョン               リポジトリー      容量
===============================================================================================
インストール中:
rsyslog-debuginfo                x86_64       8.24.0-2.el7             rsyslog_v8       2.4 M
rsyslog-doc                      x86_64       7.4.7-16.el7             base             1.0 M
rsyslog-elasticsearch            x86_64       8.24.0-2.el7             rsyslog_v8        27 k
rsyslog-gnutls                   x86_64       8.24.0-2.el7             rsyslog_v8        21 k
rsyslog-kafka                    x86_64       8.24.0-2.el7             rsyslog_v8        19 k
rsyslog-ksi                      x86_64       8.24.0-2.el7             rsyslog_v8        34 k
rsyslog-libdbi                   x86_64       8.24.0-2.el7             rsyslog_v8        15 k
rsyslog-mmanon                   x86_64       8.24.0-2.el7             rsyslog_v8        14 k
rsyslog-mmfields                 x86_64       8.24.0-2.el7             rsyslog_v8        13 k
rsyslog-mmjsonparse              x86_64       8.24.0-2.el7             rsyslog_v8        14 k
rsyslog-mmnormalize              x86_64       8.24.0-2.el7             rsyslog_v8        15 k
rsyslog-mmrm1stspace             x86_64       8.24.0-2.el7             rsyslog_v8        12 k
rsyslog-mmutf8fix                x86_64       8.24.0-2.el7             rsyslog_v8        13 k
rsyslog-mongodb                  x86_64       8.24.0-2.el7             rsyslog_v8        21 k
rsyslog-mysql                    x86_64       8.24.0-2.el7             rsyslog_v8        16 k
rsyslog-ommail                   x86_64       8.24.0-2.el7             rsyslog_v8        16 k
rsyslog-pgsql                    x86_64       8.24.0-2.el7             rsyslog_v8        14 k
rsyslog-pmaixforwardedfrom       x86_64       8.24.0-2.el7             rsyslog_v8        12 k
rsyslog-pmciscoios               x86_64       8.24.0-2.el7             rsyslog_v8        13 k
rsyslog-relp                     x86_64       8.24.0-2.el7             rsyslog_v8        22 k
rsyslog-rsgtutil                 x86_64       8.24.0-2.el7             rsyslog_v8        50 k
rsyslog-snmp                     x86_64       8.24.0-2.el7             rsyslog_v8        16 k
rsyslog-udpspoof                 x86_64       8.24.0-2.el7             rsyslog_v8        16 k
更新します:
rsyslog                          x86_64       8.24.0-2.el7             rsyslog_v8       640 k
依存性関連でのインストールをします:
libdbi                           x86_64       0.8.4-6.el7              base              42 k
libfastjson4                     x86_64       0.99.4-1.el7             rsyslog_v8        53 k
libgt                            x86_64       0.3.11-1.el7             rsyslog_v8        58 k
libksi1                          x86_64       3.4.0.7-1.el7            rsyslog_v8       108 k
liblognorm5                      x86_64       2.0.2-1.el7              rsyslog_v8        72 k
libmongo-client                  x86_64       0.1.8-1.el7              epel              46 k
libnet                           x86_64       1.1.6-7.el7              base              59 k
librdkafka                       x86_64       0.9.3-1.el7.remi         remi-safe        223 k
librelp                          x86_64       1.2.12-1.el7             rsyslog_v8        59 k
net-snmp-libs                    x86_64       1:5.7.2-24.el7_2.1       base             747 k
postgresql-libs                  x86_64       9.2.18-1.el7             base             232 k
飛ばしました (依存性の問題):
rsyslog-crypto                   x86_64       7.4.7-16.el7             base              42 k
rsyslog-gssapi                   x86_64       7.4.7-16.el7             base              41 k
rsyslog-mmaudit                  x86_64       7.4.7-16.el7             base              29 k
rsyslog-mmsnmptrapd              x86_64       7.4.7-16.el7             base              31 k
rsyslog-utils                    x86_64       8.14.0-5.el7             rsyslog_v8        45 k
トランザクションの要約
===============================================================================================
インストール                 23 パッケージ (+11 個の依存関係のパッケージ)
更新                          1 パッケージ
飛ばしました (依存性の問題)   5 パッケージ
総ダウンロード容量: 6.1 M
Is this ok [y/d/N]:

 


Written by blacknon

インフラ系のSE。一時期はプログラマ。 仮想化とオープンソースに興味あり。一日中寝てたい今日このごろ。 スペインとかで働きたいなぁ…(シエスタがあるので)

Leave a Comment

メールアドレスが公開されることはありません。

*